Задать вопрос
28 августа, 12:00

Найти сумму чисел 4-х значного числа используя линейный алгоритм

+5
Ответы (1)
  1. 28 августа, 12:23
    0
    program zz1;

    var s, n, k, p, m:integer; / / задаем переменные целого типа

    begin

    write (' введите четырехзначное число ');

    read (n); / / вводим с клавиатуры число

    k:=n mod 10; / / получаем первую цифру числа

    s:=n div 1000; / / получаем четвертую цифру числа

    p: = (n div 10) mod 10; / / получаем вторую цифру числа

    m: = (n div 100) mod 10; / / получаем третью цифру числа

    writeln (' Сумма цифр заданного четырехзначного числа = ', k + s + p + m); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму чисел 4-х значного числа используя линейный алгоритм ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Дана цепочка символов СТОП. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм) ?
Ответы (1)
Составить алгоритм и написать программу на паскале нахождение разности цифр 4-х значного числа
Ответы (1)
Известно, что 1 миля = 7 вёрст, 1 верста = 500 саженей, 1 сажень = 3 аршина, 1 аршин = 28 дюймов, 1 дюйм 25,4 мм. Пользуясь этой информацией, составьте линейный алгоритм перевода расстояния х миль в километры.
Ответы (1)