Задать вопрос

1. Напишите программу вычисления веса идеального мужчины по формуле: Ид. Вес-Рост в см - 100 Значение роста вводится с клавиатуры. Результат вывести в следующем виде: Для мужчины ростом 165 см идеальный вес равен 65 кг. 2. По аналогии с заданием №1 составить программу, определяющую идеальный вес женщины по следующей формуле: Ид. Вес=Рост в см - 100 - 10% (от Рост в см - 100)

+3
Ответы (1)
  1. 22 февраля, 01:04
    0
    1) program zz1;

    var a, b:integer; / / задаем переменные целого типа

    begin

    write (' введите рост мужчины в см '); / / вводим с клавиатуры число

    read (a);

    b:=a - 100;

    write (' Для мужчины ростом ', a, ' см. идеальный вес равен ', b, ' кг.'); / /выводим ответ

    end.

    2) program zz1;

    var a, b, c:integer; / / задаем переменные целого типа

    begin

    write (' введите рост женщины в см '); / / вводим с клавиатуры число

    read (a);

    b:=a - 100;

    c:=b - b div 10;

    write (' Для женщины ростом ', a, ' см. идеальный вес равен ', c, ' кг.'); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Напишите программу вычисления веса идеального мужчины по формуле: Ид. Вес-Рост в см - 100 Значение роста вводится с клавиатуры. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача в Паскале. с помощью оператора while напишите программу определения идеального веса для взрослых по формуле: ид. вес=рост-100. выход из цикла: значение роста=250
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Дан массив из 10 целых чисел от - 20 до 20 и целое число (вводится с клавиатуры). Напишите программу, определяющую, сколько в массиве чисел.
Ответы (1)