Задать вопрос
24 июня, 12:37

напишите программу на языке паскаля через цикл while, которая определяет максимальное из введенных чисел с клавиатуры (ввод чисел заканчивается числом 0).

+3
Ответы (1)
  1. 24 июня, 13:33
    0
    var

    a, m : integer; / / объявляем переменные целочисленного типа.

    begin

    writeln ('введите последовательность положительных чисел, окончание ввода - ноль:');

    readln (m); / / считываем первое число, считаем его максимальным.

    a: = 1;

    while a 0 do / / начало цикла.

    begin

    readln (a); / / считываем число, введенное с клавиатуры.

    if (a > m) then / / если число больше максимального.

    m : = a; / / считаем текущее число максимальным.

    end;

    write ('Максимальное число из введенной последовательности равно: ', m); / / вывод строки.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «напишите программу на языке паскаля через цикл while, которая определяет максимальное из введенных чисел с клавиатуры (ввод чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить алгоритм сложения двух целых чисел F и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной W. По данному алгоритму написать программу в Паскале. алг сложение цел F, Q, W нач ввод F ввод Q W:=F+Q вывод W кон 2.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет максимальное число. программа получает на вход целые числа, количество введенных чисел неизвестно. последовательность числа заканчивается числом 0.
Ответы (1)
Составить программу, которая вычисляет среднее арифметическое чисел. введенных с клавиатуры. Ввод чисел заканчивается, когда вводится 0. (на языке Паскаль)
Ответы (1)
Составить программу на языке pascal. используя цикл repeat ... until. Определить минимальное число из введенной с клавиатуры последовательности положительных чисел, ввод заканчивается отрицательным числом.
Ответы (1)
напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 6 и оканчивающихся на 4. Программа получает на ввод натуральные числа, количество введенных чисел неизвестно.
Ответы (1)