Задать вопрос

Запишите на языке паскаль программу решения задачи. Считайте количество жильцов дома случайным числом из диапазона от 50 до 200 человек, а число домов n=30.

+2
Ответы (1)
  1. 9 января, 23:27
    0
    Для выполнения данного действия необходимо сформировать массив и просуммировать его.

    Var

    i:integer;

    begin

    randomize;

    writeln ('Количество жильцов:');

    for i:=1 to 30 do

    writeln ('Дом ', i,' - ', random (151) + 50);

    end.

    Или по-другому:

    s:=0;

    for i:=1 to 30 do begin

    a[i]:=randon (151) + 50;

    s:=s+a[i] end;

    writeln ('s = ', s);
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Запишите на языке паскаль программу решения задачи. Считайте количество жильцов дома случайным числом из диапазона от 50 до 200 человек, а ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Запишите на языке Паскаль программу решения задачи номер 34 к § 3.4. Считайте рост претендента в команду случайным числом из диапозона от 150 до 200 см, а число претендентов n=50. (Номер задачи 34 - Объявлен набор в школьную баскетбольную команду.
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после
Ответы (1)
Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [-6; 9]. И вывести все элементы массива на экран.
Ответы (1)
Написать в Паскаль программу для решения следующей задачи. Вводится строка. Написать пользовательскую функцию, которая возвращает строку 'DA', если количество символов в ней двухзначное число и возвращает 'NET', если количество символов однозначное
Ответы (1)