Задать вопрос

Написать в Паскаль программу для решения следующей задачи. Вводится строка. Написать пользовательскую функцию, которая возвращает строку 'DA', если количество символов в ней двухзначное число и возвращает 'NET', если количество символов однозначное число.

+5
Ответы (1)
  1. 1 марта, 23:12
    0
    Var s: string;

    //описание функции

    function lng (s1: string) : string;

    begin

    if (length (S) div 10>=1) and (length (S) div 10 <10) then lng:='DA';

    if (length (S) div 10 = 0) then lng:='NET';

    if (length (S) div 10 >=10) then lng:='Число символов в строке не двухзначное или однозначное';

    end;

    //начало программы

    begin

    //ввод необходимых характеристик

    Write ('Введите строку: '); Readln (s);

    writeln (lng (s));

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать в Паскаль программу для решения следующей задачи. Вводится строка. Написать пользовательскую функцию, которая возвращает строку ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать в паскаль. Вводится две строки. Написать пользовательскую функцию которая возвращает строку 'da' если количество символов в этих строках одинаково и возвращает 'net' если неодинаково.
Ответы (1)
Написать в Паскаль программу для решения следующей задачи. Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку, добавляя после каждого символа символ '0'.
Ответы (1)
Установите взаимно-однозначное соответствие между функциями и их действием: 1) Возвращает значение, следующее за х а) chr (x) 2) Возвращает значение, предшествующее х б) pred (x) 3) Возвращает символ с кодом х, где х - целое число от 0 до 255 в)
Ответы (1)
С клавиатуры вводят строку, состоящую из латинских букв и цифр. Написать программу, которая вычисляет сумму цифр, попадающихся в этой строке, а также выводящую строку после исключения из неё этих цифр. Для паскаль abc.
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)