Задать вопрос
17 декабря, 04:54

Написать программу вычисления сопротивления электрической цепи, состоящей из 2 х сопротивлений. Сопротивления могут быть соединены параллельно или последовательно. Как должен быть реализован вывод результата на экран: Выберите тип соединения: 1 - последовательное, 2 - параллельное Введите 1 ое сопротивление Введите 2 ое сопротивление Сопротивление цепи = ... Ом

+5
Ответы (1)
  1. 17 декабря, 07:57
    0
    program rezist;

    var r1, r2: real;

    t: integer;

    begin

    writeln ('Введите тип соединения');

    writeln (' (Последовательное - 1, параллельное - 2) ');

    read (t);

    writeln ('Введите величину первого сопротивления в (Ом) ');

    read (r1);

    writeln ('Введите величину второго сопротивления в (Ом) ');

    read (r2);

    if t = 1 then writeln ('Сопротивление цепи ', r1 + r2, ' Ом');

    if t = 2 then writeln ('Сопротивление цепи ', 1 / (1/r1 + 1/r2),' Ом')

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу вычисления сопротивления электрической цепи, состоящей из 2 х сопротивлений. Сопротивления могут быть соединены ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. Сопротивления могут быть соединены последовательно или параллельно.
Ответы (1)
Написать программу в Pascal вычисления сопротивления электрической цепи, состоящей из 2-х параллельно соединенных сопротивлений. (Величина первого сопротивления 15 Ом второго сопротивления 20 Ом)
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)