Задать вопрос

Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. Сопротивления могут быть соединены последовательно или параллельно.

+1
Ответы (1)
  1. 31 августа, 12:28
    0
    program Om;

    var r1, r2: real;

    s: char;

    begin

    write ('Введите величины двух сопротивлений в омах через пробел: ');

    readln (r1, r2);

    write ('Укажите способ соединения сопротивлений (параллельно - p, последовательно - s) : ');

    readln (s);

    case s of

    'p': write ('Сопротивление цепи равно ', (1 / (1 / r1 + 1 / r2)) : 6 : 2,' ом.');

    's': write ('Сопротивление цепи равно ', (r1 + r2) : 6 : 2, ' ом.')

    end

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. Сопротивления могут быть соединены ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу вычисления сопротивления электрической цепи, состоящей из 2 х сопротивлений. Сопротивления могут быть соединены параллельно или последовательно.
Ответы (1)
Написать программу в Pascal вычисления сопротивления электрической цепи, состоящей из 2-х параллельно соединенных сопротивлений. (Величина первого сопротивления 15 Ом второго сопротивления 20 Ом)
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Три сопротивления R1, R2, R3 соединены параллельно. найти сопротивление всей цепи. Через Паскаля
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)