Задать вопрос

Даны натуральные числа n, m и двумерный массив разиером nXm. Составте программу, которая находит сумму элементов той строки, в которой расположен элемент с наименьшим сначением. Предпологается, что такой элемент единственный. (программа в паскале)

+3
Ответы (1)
  1. 4 октября, 22:20
    0
    program zz1;

    const n = 4;

    m = 7; / / задаем количество элементов в массиве

    var i, j, k, min, s:integer; / / задаем переменные целого типа

    b:array [1 ... n, 1 ... m] of integer;

    begin

    for i:=1 to n do

    for j:=1 to m do / / получаем числа и записываем их в массив

    b[i, j]:=random (201) - 100;

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to m do

    write (b[i, j]:4);

    writeln;

    end;

    min:=100000;

    for i:=1 to n do

    for j:=1 to m do

    if b[i, j] < min then begin min:=b[i, j]; k:=i; end; / / находим минимальный и запоминаем номер строки

    for j:=1 to m do

    s:=s + b[k, j];

    write (' сумма элементов массива ', k,'-ой строки = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны натуральные числа n, m и двумерный массив разиером nXm. Составте программу, которая находит сумму элементов той строки, в которой ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан двумерный массив. Найти сумму элементов этого массива. 2. В одномерном массиве сосчитать количество элементов равных 0 3. Дан двумерный массив. Найти произведение элементов каждого столбца.
Ответы (1)
1. задать двумерный массив (5 х5) случайными значениями от 5 до 10 включительно. В каждой строке найди количество элементов, значения которых >7.2. задать двумерный массив (3 х3) с клавиатуры, поменять значения элементов 1 строки с последней.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан двумерный массив размером n*m заполненный случайным образом. получить одномерный массив, элементами которого являются сумма наименьшего и наибольшего элементов соответственной строки двумерного массива (в паскале)
Ответы (1)