Задать вопрос
21 января, 23:12

Дан массив целых чисел размера N. Проверить, образуют ли его эелменты, перечисленые в том же порядке, геометрическую прогрессию. Если образуют то вывести знаменатель прогрессии, если нет то вывести 0.

+1
Ответы (1)
  1. 22 января, 00:44
    0
    program zz1;

    const n = 5; / / задаем количество элементов в массиве

    var i, k, v:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел с клавиатуры и записываем их в массив

    read (m[i]);

    k:=m[2] div m[1]; / / находим знаменатель

    for i:=1 to n-1 do

    if m[i] * k = m[i + 1] then v:=v + 1; / / проверяем, если каждое последующее число, начиная со второго,

    / / получается из предыдущего умножением его на знаменатель, то считаем его

    if v = n - 1 then write (' элементы массива образуют геометрическую прогрессию, знаменатель = ', k) else write (0);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив целых чисел размера N. Проверить, образуют ли его эелменты, перечисленые в том же порядке, геометрическую прогрессию. Если ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)