Задать вопрос

Вывести на экран все нечетные числа из последовательности чисел, вводимых с клавиатуры)) Паскаль)))

+1
Ответы (1)
  1. program zz1;

    const n=5; / /задаем количество чисел в последовательности

    var mas:array[1 ... n] of integer; / /заводим массив для хранения этих чисел

    i:integer;

    begin

    for i:=1 to n do / /организуем цикл для ввода чисел последовательности с клавиатуры

    read (mas[i]); / /записываем эти числа в массив

    for i:=1 to n do / /перебираем числа последовательности в массиве

    if mas[i] mod 2=1 then write (mas[i],' '); / /проверяем, если число не делится на два, то выводим его на экран в строчку через пробел

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вывести на экран все нечетные числа из последовательности чисел, вводимых с клавиатуры)) Паскаль))) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Напишите программу ввода чисел а, b с клавиатуры. Если a=b, то вывести на экран сумму a и b, иначе вывести на экран b-a (используя Функцию) Паскаль
Ответы (1)
Работа в экселе. Даны два числа. Если оба чётные, то вывести слово "чётные". Если оба числа нечётные, то вывести слово "нечётные", иначе (одно чётное, другое-нечётное) вывести их произведение.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)