Задать вопрос
10 февраля, 22:20

Найти произведение натуральных чисел от 1 до n

+3
Ответы (1)
  1. 10 февраля, 23:44
    0
    program zz1;

    var n, i, p:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим с клавиатуры количество нечетных чисел

    read (n);

    p:=1; / / задаем начальное значение для произведения

    for i:=1 to n do / / организуем цикл на n повторений

    begin

    p:=p * i; / / вычисляем произведение, умножая каждое следующее число из диапазона на произведение

    end;

    write (' произведение n первых натуральных чисел = ', p); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти произведение натуральных чисел от 1 до n ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Найти произведение всех натуральных чисел, кратных 3 и меньших 13. Обратите внимание, что начальное значение Р=1. 2. Найти количество натуральных чисел, нечет
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. Программа получает на вход количество чисел в последовательности и сами числа 2. Измените программу так, чтобы определялось произведение чисел. 3.
Ответы (1)