Задать вопрос

Сожмите линейный массив, удалив элементы предшествующие минимальному элементу.

+3
Ответы (1)
  1. 10 марта, 22:11
    0
    program zz1;

    const n = 14; / /задаем количество элементов в массиве

    var j, i, min, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (21);

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    min:=100000;

    for i:=1 to n do / / находим минимальный элемент и его номер

    if m[i]
    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to k do / / обнуляем элементы массива до минимального

    begin

    m[i]:=0;

    end;

    for i:=k+1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Сожмите линейный массив, удалив элементы предшествующие минимальному элементу. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дана целочисленная матрица A, размером N x M, где N, M - заданные натуральные числа. Сформировать одномерный массив B, где значение B (j) равно минимальному элементу j - ого столбца матрицы, j = Вектор (1, M).
Ответы (1)
1. Дан массив натуральных чисел. Напечатать все элементы массива, являющиеся двузначными числами. 2. Дан массив. Напечатать четные элементы. 3. Все элементы массива с четными номерами удвоить, с нечетными - уменьшить на 1.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется: for i:=0 to 10 do A[i]: = i + 1; for i:=1 to 10 do A[i]: = A[i-1];
Ответы (1)