Войти
Задать вопрос
София Румянцева
Информатика
29 сентября, 16:01
Найти сумму квадратов чисел от m до n. паскаль
+5
Ответы (
1
)
Екатерина Глухова
29 сентября, 18:27
0
program zz1;
var n, i, m, s:integer; / / задаем переменные целого типа
begin
write (' введите заданное число n '); / / вводим с клавиатуры последнее число ряда
read (n);
write (' введите заданное число m '); / / вводим с клавиатуры начальное число ряда
read (m);
for i: = m to n do / / организуем цикл, в котором переберем числа от m до n
begin
s: = s + i * i; / / возводим очередное число в квадрат, умножив на себя, и добавляем его в сумму
end;
write (' сумма квадратов чисел от m до n = ', s); / / выводим ответ
end.
Комментировать
Жалоба
Ссылка
Знаешь ответ на этот вопрос?
Отправить
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆
«Найти сумму квадратов чисел от m до n. паскаль ...»
по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
1) Составить программу нахождения суммы квадратов чисел от 25 до 125. 2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=
Ответы (1)
Задача через паскаль АБС ввести с клавиатуры 4 числа если 1 и 2 оканчивается на 5, то увеличить каждое из этих чисел в 2 раза иначе уменьшить каждое из чисел на 5 если 3 и 4 число нечётные, то вычислить сумму квадратов этих чисел иначе их
Ответы (1)
Найти квадрат суммы и сумму квадратов 2-х целых чисел, вводимых с клавиатуры. Черезе паскаль
Ответы (1)
Напишите программу, которая запрашивает четыре целых числа и выдает на экран: 1) сумму чисел; 2) сумму квадратов чисел; 3) среднее арифметическое чисел; 4) сумму парных произведений.
Ответы (1)
Нужен ответ
Расстояние между двумя пунктами 40 км. Из одного из них в другой одновременно въезжают автобус и велосипедист. Скорость автобуса 50 км в час, велосипедиста 10 км в час.
Нет ответа
Известно, что sina+cosa=a. Найдите sin2a
Нет ответа
Решите уравнение (x^2-5x+7) ^2 - (x-2) (x-3) = 1
Нет ответа
дан параллелограм АВСD. O-точка пересечения диагоналей. Найдите векторы OD-OC, 2BO + DA, CD+DB+BA
Нет ответа
1/2 это ... 4 1/3 это ... (в десятичных дробях)
Нет ответа
Главная
»
Информатика
» Найти сумму квадратов чисел от m до n. паскаль
Войти
Регистрация
Забыл пароль