Задать вопрос

1. Составить программу нахождения суммы чисел 5, 10, 15, 20, ...50. 2. Найти значения функции у = 5 х+х2, при х=50, 49, 48, 47, ..., 40.

+5
Ответы (2)
  1. 13 июля, 06:32
    0
    Продумайте алгоритм программы 1

    Алгоритм - это последовательность команд, написанная на определенном языке, выполнения которой должно решить поставленную задачу. На каком бы языке программирования не была написана программа, ее алгоритм остается неизменным. Представим программу (1) в виде алгоритма:

    задать две переменные (a, b - целочисленные числа); переменной b присвоить число 5; составить цикл суммы, который завершается при b=50; вывести результат.

    Это вариант алгоритма для решения первой задачи, который может быть написан и другим способом. Пользуясь алгоритмом, напишите программу на языке программирования C++.

    Код программы:

    #include

    using namespace std;

    int main ()

    {

    int a=0, b;

    for (b=5; b<=50; b=b+5)

    a=a+b;

    cout<<"Summa chisel ravna "<
    return 0;

    }

    Результатом программы будет строка:

    Summa chisel ravna 275

    Продумайте алгоритм программы 2

    Дана функция у = 5 х+х². Необходимо найти ее значения при х=50, 49, 48, 47, ..., 40.

    задать две переменные (x, y - целочисленные числа); перемееной x присвоить значения 50; составить цикл, который завершается при x=40. В цикл включить действия: подсчет функции, изменение x, вывод значения функции.

    Код программы:

    #include

    using namespace std;

    int main ()

    {

    int x, y;

    for (x=50; x>=40; x=x-1)

    {

    y=5*x + x*x;

    cout<<"pri x="<
    }

    return 0;

    }

    Результатом программы будут выведенные строки:

    pri x=50, funkciya y=2750

    pri x=49, funkciya y=2646

    pri x=48, funkciya y=2544

    pri x=47, funkciya y=2444

    pri x=46, funkciya y=2346

    pri x=45, funkciya y=2250

    pri x=44, funkciya y=2156

    pri x=43, funkciya y=2064

    pri x=42, funkciya y=1974

    pri x=41, funkciya y=1886

    pri x=40, funkciya y=1800
  2. 13 июля, 08:36
    0
    Составим программу вычисления суммы ряда чисел 5, 10, 15, ..., 50 на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s - сумма чисел ряда, которую надо найти, а i - порядковый номер чисел ряда. Начальное значение суммы s будет равным нулю. Так как чисел несколько, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 5, с интервалом 4 числа, поэтому значение i в каждом цикле будем увеличивать на 4.

    Программа может выглядеть так:

    program zadacha;

    uses crt;

    var s, i: integer;

    begin

    s:=0; {Задание начального значение суммы s}

    for i:=5 to 50 do begin

    s:=s+i; {Вычисление суммы чисел}

    i:=i+4; {Увеличение значения параметра i на 4}

    end;

    writeln ('s=', s) {Вывод результата суммы s}

    end.

    Можно решить данную задачу и вторым способом, используя операцию mod:

    program zadacha;

    uses crt;

    var s, i: integer;

    begin

    s:=0; {Задание начального значение суммы s}

    for i:=5 to 50 do

    if i mod 5=0 {Поиск чисел, кратных 5}

    then s:=s+i; {Вычисление суммы чисел}

    writeln ('s=', s); {Вывод результата суммы s}

    end.

    Ответом будет s=275.

    Составить программу нахождения значения функции у = 5 х+х2, при х=50, 49, 48, 47, ..., 40.

    program zadacha;

    uses crt;

    var x, y, i:integer;

    begin

    for i:=50 downto 40 do begin y:=5*i+i*2; writeln ('y=', y); end;

    writeln ('y=', y)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Составить программу нахождения суммы чисел 5, 10, 15, 20, ...50. 2. Найти значения функции у = 5 х+х2, при х=50, 49, 48, 47, ..., 40. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике