Задать вопрос

Составить программу в Паскаль: Даны 4 числа, выделить целые части и найти среднее арифметическое этих чисел.

+4
Ответы (1)
  1. 8 августа, 02:54
    0
    program zz1;

    var a, b, c, d:real; / /задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    write (' введите четвертое число '); / / вводим с клавиатуры четвертое число

    read (d);

    writeln (' целая часть числа ', a, ' = ', trunc (a)); / / выводим ответы

    writeln (' целая часть числа ', b, ' = ', trunc (b));

    writeln (' целая часть числа ', c, ' = ', trunc (c));

    writeln (' целая часть числа ', d, ' = ', trunc (d));

    writeln (' среднее арифметическое = ', (a + b + c + d) / 4);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу в Паскаль: Даны 4 числа, выделить целые части и найти среднее арифметическое этих чисел. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы