Задать вопрос
8 февраля, 14:23

Введите с клавиатуры 4 числа. Вывести на экран номер наибольшего числа. Это по паскалю.

+1
Ответы (1)
  1. 8 февраля, 17:54
    0
    program zz1;

    var a, b, c, d, max:integer; / /задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    write (' введите четвертое число '); / / вводим с клавиатуры четвертое число

    read (d);

    if (a>b) and (a>c) and (a>d) then max:=1;

    if (b>a) and (b>c) and (b>d) then max:=2;

    if (c>b) and (c>a) and (c>d) then max:=3;

    if (d>b) and (d>c) and (d>a) then max:=4;

    writeln (' номер максимального из четырех чисел = ', max); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Введите с клавиатуры 4 числа. Вывести на экран номер наибольшего числа. Это по паскалю. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программу ввода чисел а, b с клавиатуры. Если a=b, то вывести на экран сумму a и b, иначе вывести на экран b-a (используя Функцию) Паскаль
Ответы (1)