Задать вопрос
14 декабря, 18:01

Заполнить массив 20-ю случайными числами так, чтобы числа не повторялись.

+1
Ответы (1)
  1. 14 декабря, 18:51
    0
    program arr;

    const b=40; / /можно задать другое число, которое больше 19.

    var a:array [1 ... 20] of integer;

    p, flag: integer;

    begin

    randomize;

    for i: integer: = 1 to 20 do

    begin

    a[i]:=random (b) + 1;

    if i > 1 then for j: integer:=1 to i - 1 do

    if a[i] = a[j] then

    begin

    flag: = 0;

    while flag = 0 do

    begin

    flag: = 1;

    a[i]: = random (b) + 1;

    for k: integer: = 1 to i - 1 do if a[i] = a[k] then

    begin

    p: = 0;

    flag: = flag * p

    end

    end

    end

    end;

    for k: integer: = 1 to 20 do writeln (a[k] : 3)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Заполнить массив 20-ю случайными числами так, чтобы числа не повторялись. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Помогите написать программу в паскале. Заполните массив из N элементов случайными числами в интервале [1, N] так, чтобы в массив обязательно вошли все числа от 1 до N (постройте случайную перестановку). Пример: Массив: 3 2 1 4 5
Ответы (1)
Задать массив из 8 элементов целого типа. Заполнить массив случайными значениями из интервала (-10; 10) и вывести массив. Найти сумму и количество четных, а также произведение и количество нечетных значений элементов массива.
Ответы (1)