Задать вопрос

дан массив R (7) R=12,-12, 49, 16, - 4, 33, 94 значение элементов данного массива увеличить в 2 раза и поместить в новый массив который называется S (7) посчитать сколько раз в массиве R встречаются элементы меньше 0

+4
Ответы (1)
  1. 3 апреля, 21:22
    0
    program zz1;

    const n = 7; / / задаем количество элементов в массиве

    R:array [1 ... n] of integer = (12,-12, 49, 16, - 4, 33, 94);

    var i, k:integer; / / задаем переменные целого типа

    S:array [1 ... n] of integer;

    begin

    for i:=1 to n do S[i]:=R[i];

    for i:=1 to n do write (S[i], ' ');

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    if R[i] < 0 then k:=k + 1; / / проверяем, если элемент отрицательный, то считаем его

    write (' количество отрицательных элементов = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «дан массив R (7) R=12,-12, 49, 16, - 4, 33, 94 значение элементов данного массива увеличить в 2 раза и поместить в новый массив который ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)