Задать вопрос

В одномерном массиве найти максимальный элемент заменить на 0, и вывести массив на экран. На паскале.

+1
Ответы (1)
  1. 11 декабря, 19:09
    0
    program zz1;

    const n = 4; / /задаем количество элементов в массиве

    var i, max1, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (21);

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    max1:=0;

    for i:=1 to n do / / находим максимальный элемент и его номер

    if m[i]>max1 then begin max1:=m[i]; k:=i; end;

    m[k]:=0;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В одномерном массиве найти максимальный элемент заменить на 0, и вывести массив на экран. На паскале. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Дан массив состоящий из 30 элементов. Найти в массиве максимальный элемент, вывести его значение и номер на экран. Отрицательный элемент массива заменить на равные по модулю положительные элементы.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)