Задать вопрос

Найти сумму 23 первых натуральных чисел, которые при делении на 8 дают остаток 5. В паскаль

+5
Ответы (1)
  1. 10 декабря, 13:58
    0
    program zz1;

    var k, b, i:integer; / / задаем переменные целого типа

    begin

    i:=1; k:=0; / / задаем начальное значение для параметра цикла и количества искомых чисел

    while k < = 23 do / / организуем цикл, пока параметр цикла не достигнет 23

    begin

    if i mod 8 = 5 then begin b:=b + i; k:=k + 1; end; / / проверяем, если число при делении на 8, в остатке дает 5, то добавляем число к сумме

    i:=i + 1; / / увеличиваем параметр цикла на единицу

    end;

    write (' сумма 23 первых натуральных чисел, которые при делении на 8 дают остаток 5 = ', b); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму 23 первых натуральных чисел, которые при делении на 8 дают остаток 5. В паскаль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Найти все четырехзначные числа, которые при делении на 3 дают остаток 1, при делении на 4 - остаток 2, а сумма их цифр равна А. (А-вводится с клавиатуры)
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Паскаль Дан массив А (50) целых чисел. Найти сумму и количество тех элементов массива, которые при делении на 7 дают остаток 1, 2 или 5.
Ответы (1)
Ввести с клавиатуры n целых чисел. Найти произведение и количество чисел, которые при делении на 7 дают остаток 5.
Ответы (1)
1. Вычислить значение переменной Y при заданном значении N: Y=1/1+1/2+1/3 + ... + 1/N. использовать цикл типа ДО. (Паскаль) 2. Найти все целые двузначные числа, удовлетворящие условию: остаток от деления на 3 равен 2. (Паскаль)
Ответы (1)