Задать вопрос

Pascal. для функции y=x (x-1) ^2 (x-2) ^3 записать в массив В значение аргумента х на интервале [-0,3; 0,5] и найти минимум этой функции и соответствующее значение аргумента

+1
Ответы (1)
  1. 10 декабря, 21:27
    0
    program zz1;

    const n = 9; / / задаем количество элементов в массиве

    var i:integer; / / задаем переменные целого типа

    x, k, min:real;

    y:array [1 ... n] of real;

    begin

    min:=100000; / / задаем начальное значение для минимума функции

    x:=-0.3; / / задаем начальное значение для аргумента функции

    while x < = 0.5 do

    begin

    i:=i + 1;

    y[i]:=x * sqr (x - 1) * (sqr (x - 2) * (x - 2));

    x:=x + 0.1;

    if y[i] < min then begin min:=y[i]; k:=x; end;

    end;

    write (' минимум функции = ', min, ' значение аргумента функции = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Pascal. для функции y=x (x-1) ^2 (x-2) ^3 записать в массив В значение аргумента х на интервале [-0,3; 0,5] и найти минимум этой функции и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Помогите написать программу в паскале. Заполните массив из N элементов случайными числами в интервале [1, N] так, чтобы в массив обязательно вошли все числа от 1 до N (постройте случайную перестановку). Пример: Массив: 3 2 1 4 5
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)