Задать вопрос

2. Составить программу, определяющую, существует ли треугольник, длины сторон которого равны a, b и с.

+3
Ответы (1)
  1. 19 сентября, 17:30
    0
    program zz1;

    var a, b, c:integer; / / задаем переменные целого типа

    begin

    write (' введите первую сторону треугольника ');

    read (a);

    write (' введите вторую сторону треугольника ');

    read (b);

    write (' введите третью сторону треугольника ');

    read (c);

    If (a + b > c) and (c + b > a) and (a + c > b) / / проверяем условие существования треугольника, если условие верное, то

    Then write (' существует ') / / выводим один ответ

    else write (' не существует '); / / иначе, выводим другой ответ

    END.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «2. Составить программу, определяющую, существует ли треугольник, длины сторон которого равны a, b и с. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его типИмеются данные о количестве полных лет трех призеров спартакиады.
Ответы (1)
Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.
Ответы (1)
Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс.
Ответы (1)
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
1) Написать программу вывода всех четных чисел от 2 до 1000 включительно2) Написать программу определяющую сумму всех нечетных чисел от 1 до 99
Ответы (1)