Задать вопрос

Нужно написать программу на языке Паскаль, которая будет убирать из строки все символы кроме цифр. Пример: входной - a3f4h5k&2 выходной: 3452

+3
Ответы (1)
  1. 23 апреля, 09:40
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    i:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    for i:=length (s) downto 1 do / / организуем цикл, в котором переберем все символы от последнего до первого

    begin

    if (s[i] = '1') or (s[i] = '2') or (s[i] = '3') or (s[i] = '4') or (s[i] = '5') or (s[i] = '6') or

    (s[i] = '7') or (s[i] = '8') or (s[i] = '9') or (s[i] = '0')

    then

    else

    delete (s, i, 1);

    end;

    write ('полученная строка = ', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Нужно написать программу на языке Паскаль, которая будет убирать из строки все символы кроме цифр. Пример: входной - a3f4h5k&2 выходной: ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
С клавиатуры вводят строку, состоящую из латинских букв и цифр. Написать программу, которая вычисляет сумму цифр, попадающихся в этой строке, а также выводящую строку после исключения из неё этих цифр. Для паскаль abc.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Дана строка-предложение. Зашифровать ее, поместив вначале все символы, расположенные на четных позициях строки, а затем, в обратном порядке, все символы, расположенные на нечетных позициях.
Ответы (1)
Напишите программу в Паскале, которая выводит на экран только нечётные символы (символы под номерами 1, 3, 5, ...) из текста пользователя.
Ответы (1)