Задать вопрос

Дан массив целых чисел из 8 элементов Указать те их них, у которых остаток от деления на M равен 1. (Pascal)

+4
Ответы (1)
  1. 16 апреля, 01:42
    0
    program zz1;

    const n = 8; / / задаем количество элементов в массиве

    var i, M:integer; / / задаем переменные целого типа

    mas:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    mas[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (mas[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    write (' введите заданное M ');

    read (M);

    for i:=1 to n do

    if mas[i] mod M = 1 then write (mas[i], ' '); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив целых чисел из 8 элементов Указать те их них, у которых остаток от деления на M равен 1. (Pascal) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)