Задать вопрос

Написать программу, которая просит пользователя ввести три числа и находит их среднее арифметическое

+2
Ответы (1)
  1. 15 августа, 01:31
    0
    Program ch3;

    a, b, c: integer;

    s: real;

    begin

    writeln ('Введите 3 целых числа через пробел');

    readln (a, b, c);

    s: = (a+b+c) / 3;

    writeln ('Среднее арифметическое чисел равно: ', s);

    readln;

    end.

    Обязательно обратить внимание на то, что даже если исходные числа мы взяли целыми, переменной для среднего арифметического необходимо присвоить тип данных real, так как этой переменной присваивается формула, содержащая деление, а оно на множестве integer использоваться не может.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая просит пользователя ввести три числа и находит их среднее арифметическое ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
1) Написать программу, которая находит в массиве случайных символов первое вхождение заданного символа.
Ответы (1)
Ввести три числа, найти их сумму произведение и среднее арифмитическое Пример. Ввести 3 числа 457 4+5+7=16 4*5*7=140 (4+5+7) / 3=5,3 (3) Через программу Python
Ответы (1)
Напишите программу которая спросит имя пользователя и класс в котором он учится а затем выдаст строку здравствуй если введено число класса до 9 то написать ты ещё не знаешь паскаль если больше то давай поработаем если это какой либо другой символ
Ответы (1)
Ввести три числа найти их разность и среднее арифметическое. (написать программу в паскаль)
Ответы (1)