Задать вопрос

Дана строка. Удалить из нее все пробелы. Программа Паскаль

+4
Ответы (1)
  1. 20 января, 09:42
    0
    program space_del;

    var s: string; //строковая переменная

    k:integer;

    begin

    writeln ('Enter text ');

    readln (s); //ввод строки текста с пробелами

    k:=0; //значение k для входа в цикл

    repeat

    k:=pos (' ', s); / /номер позицииб на которой стоит пробел

    Delete (S, k, 1); / /удаляется пробел с позиции k

    until k<1; / /если пробел не найден, k будет равно 0;

    / / цикл остановится

    write (s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана строка. Удалить из нее все пробелы. Программа Паскаль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана строка (прочитать из файла). Удалить из неё все знаки препинания (.; :,!?). Результат вывести на экран.
Ответы (1)
Установите соответствие: 1) базовое системное ПО а) операционная система 2) утилиты б) программа диагностики дисков в) антивирусная программа г) операционная оболочка д) программа архивации данных e) программа обслуживания сети
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Дана строка, выбрать из нее все цифры и упорядочить по возрастанию. (паскаль АВС)
Ответы (1)
Дана исходная строка: "12". Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на четных позициях считая слева направо, прибавили по 1. Получилась строка: "1322".
Ответы (1)