Задать вопрос

дано трёхзначное число. верно ли что оно состоит из одинаковых цифр. решите через паскаль.

+2
Ответы (1)
  1. 13 августа, 13:05
    0
    program zz1;

    var n, a, b, c:integer;

    begin

    write (' введите трехзначное число ');

    read (n); / / вводим с клавиатуры число

    a: = (n div 100) mod 10; / / находим первую цифру числа

    b: = (n div 10) mod 10; / / находим вторую цифру числа

    c:=n mod 10; / / находим третью цифру числа

    if (a = b) and (b = c) / / проверяем условие, если цифры равны

    then writeln (' заданное трехзначное число состоит из одинаковых цифр ') / / выводим ответы

    else writeln (' заданное трехзначное число состоит не из одинаковых цифр ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «дано трёхзначное число. верно ли что оно состоит из одинаковых цифр. решите через паскаль. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Написать в программе Паскаль: Дано целое число. Если оно положительное и трехзначное, найти сумму первой и третьей цифры этого числа, в противном случае сообщить, что число нам не подходит.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)