Задать вопрос

Выведите на экран все двузначные числа, которые при возведении в квадрат дают палиндром.

+1
Ответы (3)
  1. 10 августа, 11:51
    0
    program n1;

    var i, k, x, y:integer;

    begin

    for i:=10 to 99 do begin

    k:=i*i;

    if (k div 1000=0) then

    if (k div 100=k mod 10) then writeln (i)

    else begin

    x:=k div 100;

    y:=k mod 100;

    if (x mod 10=y div 10) and (x div 10=y mod 10) then writeln (i);

    end;

    end;

    end.

    Ответ: 11, 22, 26
  2. 10 августа, 12:02
    0
    Вот держи на языке паскаль: Var x, i:integer; Begin For i:=10 to 99 do If (i = 32) and ((i*i div 100) = (i*i mod 10) * 10 + ((i*i div 10) mod 10)) then writeln (i); end.
  3. 10 августа, 13:06
    0
    Var x, a:integer; begin x:=10; while (x<100) do begin a:=x*x; if (a<999) then begin if (((a mod 10) * 100 + ((a mod 100) div 10) * 10 + (a div 100)) = a) then writeln (x); end else begin if (((a mod 10) * 1000 + ((a mod 100) div 10) * 100 + ((a mod 1000) div 100) * 10 + (a div 100)) = a) then writeln (x); end; x:=x+1; end; end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Выведите на экран все двузначные числа, которые при возведении в квадрат дают палиндром. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Число называется палиндромом, если справа налево и слева направо читается одинаково. Например, 12321 - палиндром. Найдите ближайший палиндром, больший числа 13244. Пример: для числа 12 ближайший палиндром, больший него, это 22.
Ответы (1)
Число называется палиндромом, если справа налево и слева направо читается одинаково. Например, 12321 - палиндром. Найдите ближайший палиндром, больший числа 81247. Пример: для числа 12 ближайший палиндром, больший него, это 22.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Введите строку символов; определите и выведите на экран ее длину. выведите на экран первый и последний символ этой строки (через Паскаль)
Ответы (1)