Задать вопрос

Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от - 20 до 20 и отрицательные числа возводит в квадрат, а из неотрицательных извлекает квадратный корень.

+1
Ответы (1)
  1. 3 февраля, 15:38
    0
    program zz1;

    const n = 15; / / задаем количество элементов в массиве

    var i:integer; / / задаем переменные целого типа

    m:array [1 ... n] of real;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (41) - 20;

    for i:=1 to n do / / выводим исходный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    begin

    if m[i] < 0 then m[i]:=m[i]*m[i]

    else m[i]:=sqrt (m[i]);

    end;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i]:7:2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от - 20 до 20 и отрицательные числа возводит в квадрат, а ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы