Задать вопрос

Дан массив из 7 целочисленных элементов. Элементы вводятся с клавиатуры (все элементы различны). Найти максимальный элемент численного массива.

+3
Ответы (1)
  1. 15 июня, 14:59
    0
    program zz1;

    var mas:array[1 ... 7] of integer;

    i, max:integer;

    begin

    for i:=1 to 7 do / /вводим семь исходных чисел в массив с клавиатуры

    read (mas[i]);

    max:=0; / /задаем начальное значение максимального числа

    for i:=1 to 7 do

    if mas[i]>max then max:=mas[i]; / /проверяем, если число из массива больше максимального, то в максимальное записываем это число

    writeln ('максимальный элемент массива=', max); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из 7 целочисленных элементов. Элементы вводятся с клавиатуры (все элементы различны). Найти максимальный элемент численного ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан массив из 8 целочисленных элементов. Элементы вводятся с клавиатуры (все элементы различны). Найти минимальный элемент численного массива и его порядковый номер.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан массив С размеров 10 элементов, элементы вводятся с клавиатуры. а) Найти сумму отрицательных элементов массива б) Поменять 1 и 5 элементы местами в) выполнить сортировку массива по возрастанию методом "пузырька"
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)