Задать вопрос

Дана последовательность из n целых чисел. Определить, есть ли в ней число, равное первому из этой последовательности.

+3
Ответы (1)
  1. 28 апреля, 23:20
    0
    program zz1;

    const n = 13; / / задаем количество элементов в последовательности

    R:array [1 ... n] of integer = (26, - 53, 0, - 67, 12, - 34, 0, 90, 14, - 78, 26, - 45, 66); / / задаем последовательность чисел

    var i, m:integer; / / задаем переменные целого типа

    begin

    for i:=2 to n do / / организуем цикл, в котором переберем все числа в последовательности

    if R[i] = R[1] then m:=1; / / проверяем, если число последовательности равено первому, то запоминаем это событие

    if m = 1 then writeln (' в последовательности есть число равное первому числу ')

    else writeln (' в последовательности нет числа равного первому числу '); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность из n целых чисел. Определить, есть ли в ней число, равное первому из этой последовательности. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Вводится последовательность целых чисел, оканчивающаяся нулем. Число 0 в последовательность не входит. Выведите элементы последовательности в обратном порядке. Для хранения данных используйте стек.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
1. Дан массив натуральных чисел. Найти сумму элементов кратных данному К. 2. В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. 3. дана последовательность целых чисел а1, а2, ... аn.
Ответы (1)
В PascalABC дана последовательность целых чисел, в этой последовательности есть два нуля, располагаются они в разных местах, надо найти количество чисел стоящих между этими нулями.
Ответы (1)