Задать вопрос

В массиве все элементы >10 и <20 заменить на первый элемент массива

+3
Ответы (1)
  1. 7 сентября, 06:22
    0
    program zz1;

    const n = 15; / / задаем количество элементов в массиве

    var i:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (31);

    for i:=1 to n do / / выводим исходный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if (m[i] > 10) and (m[i] < 20) then m[i]:=m[1];

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве все элементы >10 и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве из 70 целых чисел найти количество элементов, кратных 3 2. Проверить, что в массиве ровно 3 одинаковых максимальных числа 3. В массиве удалить все элементы, имеющие нечетные значения
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
Сначала задано число N - количество элементов в массиве. Далее через пробел записаны N чисел - элементы массива. Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)