Задать вопрос
14 декабря, 19:37

Найти среднее арифметическое минимального и максимального элементов из 10 введенных

+5
Ответы (1)
  1. 14 декабря, 21:53
    0
    program zz1;

    var a, b, min, i, max:integer; / / задаем переменные целого типа

    begin

    min:=10000; max:=0; / / задаем начальные значения для максимального и минимального

    for i:=1 to 10 do

    begin

    read (a); / / вводим число

    if a > max then max:=a; / / проверяем, если число больше максимального, то записываем его в максимальное

    if a < min then min:=a; / / проверяем, если число меньше минимального, то записываем его в минимальное

    end;

    write (' среднее арифметическое минимального и максимального элементов = ', (max + min) / 2); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти среднее арифметическое минимального и максимального элементов из 10 введенных ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)
Дан одномерный массив (50 элементов) случайных чисел в диапазоне от 10 до 50. Найти и вывести номер и значение максимального элемента, номер и значение минимального элемента, среднее арифметическое всех чисел стоящих на четным местах.
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
Написать программу, которая в одномерном массиве, заданном вводом с клавиатуры вычисляет среднее арифметическое массива без максимального и минимального элемента массива.
Ответы (1)