Задать вопрос

Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов = 2 { это пары (10,2), (2,4) }

+4
Ответы (1)
  1. 1 марта, 04:01
    0
    Для составления такой программы может быть использована следующая логика: мы создаем массив и заполняем его числами.

    Далее составляем цикл, который будет рассматривать каждый элемент массива от первого до предпоследнего включительно. Нам не нужен будет последний, так как он будет с кем-то в паре, если будет четным. А если нет - то пары для него больше не будет, потому что он последний.

    Еще нужен будет внутренний цикл, проверяющий пару для элемента первого цикла:

    var a:array [1 ... 8] of integer;

    temp_para : integer;

    begin

    for i:integer≔1 to 8 do

    a[i] ≔ random (9) + 1;

    for i:integer≔1 to 7 do

    begin

    if (a[i] mod 2 = 0) then

    temp_paraa ≔ a[i];

    for k:integer ≔ I + 1 to 8 do

    if (a[k] mod 2 = 0) then

    begin

    writeln ('Найдена пара ', a[i], ', ', a[k]);

    break;

    end;

    end;
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и вычисляет произведение элементов массива с чётными значениями и среднее арифм. элементов массива с нечётными значениями
Ответы (1)
Составьте программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Составьте программу, которая заполняет массив a[1 ... 10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с четными значениями
Ответы (1)
Составьте программу. которая заполняет массив b [1 ... 8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элемеyтов с нечётными значениями
Ответы (1)