Задать вопрос

Даны действительные числа a и b если а<=b, то первое число увеличить в два раза, а ко второму числу добавить 5, в противном случае числа уменьшить на 5

+5
Ответы (1)
  1. 26 марта, 23:06
    0
    program zz1;

    var a, b, x0, x1:real; / / задаем переменные не целого типа

    begin

    write (' введите первое действительное число '); / / вводим с клавиатуры не целое число

    read (a);

    write (' введите второе действительное число '); / / вводим с клавиатуры не целое число

    read (b);

    If (a < = b) / / проверяем, если первое число меньше или равно второго, то

    Then begin a:=a * 2; b:=b + 5; end / / первое увеличиваем в два раза, а второе увеличиваем на пять

    else begin a:=a - 5; b:=b - 5; end; / / уменьшаем оба числа на пять

    write (' a = ', a, ' b = ', b); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны действительные числа a и b если а ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Даны действительные числа x, y. Вывести на экран то из них, которое меньше. Даны два символа (латинские буквы). Вывести их на экран в порядке возрастания по алфавиту. Полный бидон с молоком весит p кг. Бидон, наполненный наполовину, весит q кг.
Ответы (1)
Даны действительные числа a, b. Вывести на экран сообщение "Числа лежат в заданном промежутке", если они принадлежат интервалу (x0, x1] и "Числа вне интервала" в противном случае (приделы интервала x0 и x1 вводятся с клавиатуры)
Ответы (1)
Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)
Ответы (1)
Даны действительные числа а, b, с. Удвоить эти числа, если а ≥ b ≥ с, и заменить их абсолютными значениями, если это не так.
Ответы (1)
даны действительные положительные числа a, d, c, b вычислить существует ли прчмоугольник с такими сторонами
Ответы (1)