Задать вопрос
30 ноября, 12:08

Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)

+1
Ответы (1)
  1. 30 ноября, 15:56
    0
    program zz1;

    var x, y, z:real; / / задаем переменные не целого типа

    begin

    write ('введите первое действительное число '); / / вводим с клавиатуры не целое число

    read (x);

    write ('введите второе действительное число '); / / вводим с клавиатуры не целое число

    read (y);

    write ('введите третье действительное число '); / / вводим с клавиатуры не целое число

    read (z);

    If (x > 0) and (y > 0) and (z > 0) / / проверяем, если первое число меньше второго, то

    Then begin x:=x * 2; y:=y * 2; z:=z * 2; end

    else begin if x < 0 then x:=abs (x); if y < 0 then y:=abs (y); if z < 0 then z:=abs (z); end;

    write (' x = ', x, ' y = ', y, ' z = ', z); / / выводим ответ

    END.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить программу в паскале, в которой: а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345. б) Подсчитать и вывести отрицательные элементы массива
Ответы (1)
Составить программу в Паскале Даны действительные положительные числа x, y, z. выяснить существует ли треугольник с данными сторонами
Ответы (1)
даны натуральное число n, действительные числа а1, ..., аn. В последовательности а1, ..., аn все отрицательные члены увеличить на 0,5 а все неотрицательные заменить на 0,1.
Ответы (1)
Написать программу паскале: Даны два числа. Увеличить каждое из них в два раза, если их сумма четная, в противном случае увеличить в два раза только первое число.
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)