Задать вопрос

10. Проверить является ли заданная строка шестизначным числом, записанным в десятичной системе счисления без нулей в старших разрядах. - пример правильных выражений: 123456, 234567. - пример неправильных выражений: 1234567, 12345.

+5
Ответы (1)
  1. 25 марта, 14:55
    0
    Сначала проверим, сколько вообще знаков содержит введенная строка. Если их будет больше, чем шесть или меньше, чем шесть, будем останавливать алгоритм и выводить сообщение об ошибке.

    Если их будет ровно шесть, отделим первый символ и рассмотрим его. По условию задачи в старших разрядах не должно содержаться нулей.

    Если первый символ не ноль, выводим сообщение о том, что строка - шестизначное число.

    var perem:string;

    begin

    if length (perem) 6 then

    writeln ('В строке не шесть знаков!')

    else

    if perem[1] '0' then

    writeln ('Число является шестизначным');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «10. Проверить является ли заданная строка шестизначным числом, записанным в десятичной системе счисления без нулей в старших разрядах. - ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Какие целые числа за числами: а) 101011 - в двоичной системе счисления б) 7777 - в восьмеричной системе счисления в) CDEF - в шестнадццатеричной системе счисления 2.
Ответы (1)
Выполнить сложение в восьмеричной системе счисления 238+758 результат представить в двоичной системе счисления Выполнить сложение в шестнадцатеричной системе счисления 1416+3 В16. результат представить в двоичной системе счисления
Ответы (1)
Вычислите значение арифметического выражения 10110 в двоичной системе счисления + 34 в восьмеричной системе счисления + 15 в десятичной системе счисления
Ответы (1)
1) Как представлено число 56 (8) в двоичной системе счисления? 2) какое из чисел следует за числом А1 (16) в шестнадцатиричной системе 3) сколько значащих нулей в двоичной записи числа 254 (10) ?
Ответы (1)
5. Системы счисления. a. Переведите данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления: 114,22510 b. Переведите данные числа в десятичную систему счисления: 100111100,11012 1234,58 2B3, F416 c.
Ответы (1)