Задать вопрос

Составить программу, в которой вводится массив, используя датчик случайных чисел, сортируется массив по убыванию.

+1
Ответы (1)
  1. 7 июня, 08:24
    0
    program zz1;

    const n = 30; / / задаем количество чисел в массиве

    var i, k, j, b:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51) + 150;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i : = 1 to n-1 do / / сортируем по убыванию

    for j : = 1 to n-i do

    if m[j] < m[j+1] then begin

    b : = m[j];

    m[j] : = m[j+1];

    m[j+1] : = b

    end;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, в которой вводится массив, используя датчик случайных чисел, сортируется массив по убыванию. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы