Задать вопрос

Составить программу нахождения минимального элемента в массиве заполненным используя датчик случайных чисел из промежутка [-50; 50]

+3
Ответы (1)
  1. 21 мая, 07:09
    0
    var

    min, i : integer; / / объявляем переменные целочисленного типа.

    arr : array [1 ... 50] of integer; / / объявляем массив.

    Begin

    for i: = 1 to 50 do / / начало цикла.

    begin

    arr[i] : = random (-50,50); / / заполняем элемент массива с индексом i случайным числом.

    if arr[i] < min then / / если элемент массива меньше минимума.

    min : = arr[i]; / / делаем текущий элемент массива минимальным.

    write (arr[i],' '); / / вывод на экран текущего элемента массива.

    end;

    writeln ('Минимальный элемент массива = ', min); / / вывод строки на экран.

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу нахождения минимального элемента в массиве заполненным используя датчик случайных чисел из промежутка [-50; 50] ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
нужно составить программу для нахождения минимального элемента и его индекса в целочисленном массиве a из 10 элементов заполненных числами из интервала - 48; 86
Ответы (1)
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)
Составить программу, в которой вводится массив, используя датчик случайных чисел, сортируется массив по убыванию.
Ответы (1)
Дан одномерный массив (50 элементов) случайных чисел в диапазоне от 10 до 50. Найти и вывести номер и значение максимального элемента, номер и значение минимального элемента, среднее арифметическое всех чисел стоящих на четным местах.
Ответы (1)
Составить программу, которая формирует массив из 10 случайных чисел от 0 до 50 и осуществляет поиск минимального элемента
Ответы (1)