Задать вопрос

Дано N случайных чисел в диапазоне от - 3 до 3. Вычислите, сколько из них не совпадают с 0. Составить программу, используя цикл for. Для задания случайных ч исел используйте функцию random. N определяет пользователь. Числа вывести на экран.

+2
Ответы (1)
  1. 16 октября, 19:33
    0
    program zz1;

    var n, i, a, s:integer; / / вводим переменные целого типа

    begin

    write (' введите число n '); / / вводим с клавиатуры число

    read (n);

    for i:=1 to n do / / организуем цикл на n повторений

    begin

    a:=random (7) - 3; / / получаем случайное число в заданном диапазоне

    write (a,' '); / / выводим на экран полученные числа через пробел

    if a 0 then s:=s + 1; / / считаем количество чисел не совпадающих с нулем

    end;

    write (' количество чисел не совпадающих с нулем = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано N случайных чисел в диапазоне от - 3 до 3. Вычислите, сколько из них не совпадают с 0. Составить программу, используя цикл for. Для ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Для генерации случайного целого числа из промежуток [10; 20) необходимо использовать выражение: а) random * 20 б) random (20) в) random (20) + 10 г) random (10) * 2
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Дан двумерный массив вывести на экран "да" если первый и последний столбец совпадают если не совпадают то вывести на экран "нет" решить в pascal
Ответы (1)