Задать вопрос

Напишите программу: ввести четырехзначное число, найти сумму крайних и сумму средних цифр

+4
Ответы (1)
  1. 6 февраля, 21:38
    0
    На Pascal:

    program sum4; uses crt; var a:integer;

    begin writeln ('Введите 4-х значное число'); readln (a); writeln ('Сумма крайних цифр = ', (a mod 10) + (a div 1000)); writeln ('Сумма средних цифр = ', ((a div 100) mod 10) + (a div 10) mod 10); end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу: ввести четырехзначное число, найти сумму крайних и сумму средних цифр ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
Ввести три числа, найти их сумму произведение и среднее арифмитическое Пример. Ввести 3 числа 457 4+5+7=16 4*5*7=140 (4+5+7) / 3=5,3 (3) Через программу Python
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)