Задать вопрос

найти среднее арифметическое всех чисел от 100 до 900. в цикле с параметром

+2
Ответы (1)
  1. 2 июля, 23:34
    0
    program zz1;

    var r, i, k:integer; / / задаем переменные целого типа

    begin

    for i:=100 to 900 do / / организуем цикл, в котором переберем все числа от ста до девятисот

    begin r:=r + i; k:=k + 1; end; / / добавляем число к сумме и считаем количество

    write (' среднее арифметическое всех чисел от 100 до 900 = ', r / k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «найти среднее арифметическое всех чисел от 100 до 900. в цикле с параметром ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массиа А, состоящий из 12 чисел, массив заполнить случайными числами в диапазоне от 0 до 100. Требуется подсчитать среднее арифметическое значение элементов массива. на экран вывести массив и среднее арифметическое
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Дан массив из 15 чисел заполненный случайными числами из интервала [-20; 20]. определить, что больше среднее арифметическое элементов стоящих на четных местах или среднее арифметическое положительных элементов массива
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)