Задать вопрос

Напишите программу выводящую сумму всех натуральных чисел до числа n

+2
Ответы (1)
  1. 30 марта, 06:19
    0
    program zz1;

    var n, s, i: integer; / / задаем переменные целого типа

    begin

    s: = 0; / / задаем начальное значение суммы

    read (n); / / вводим заданное число n с клавиатуры

    i:=1; / / задаем значение первого натурального числа

    while i < = n do / / организуем цикл, пока натуральное число не станет больше заданного n

    begin

    s:=s + i; / / прибавляем очередное натуральное число к сумме

    i: = i + 1; / / берем следующее натуральное число

    end;

    write (' полученная сумма чисел = ', s); / / выводим ответ на экран

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу выводящую сумму всех натуральных чисел до числа n ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. Программа получает на вход количество чисел в последовательности и сами числа 2. Измените программу так, чтобы определялось произведение чисел. 3.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)
Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран: а) количество нулей в последовательности; б) количество положительных чисел; в) количество отрицательных чисел.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)