Задать вопрос
25 июля, 11:11

Дан массив из n элементов. Найти наименьший элемент массива. Написать в паскале абс

+1
Ответы (1)
  1. 25 июля, 11:43
    0
    program zz1;

    const n=10; / /задаем количество элементов в массиве

    var mas:array[1 ... n] of integer;

    i, min:integer;

    begin

    for i:=1 to n do

    mas[i]:=random (20) + 1; / /вводим числа в массив рандомно от 1 до 20

    for i:=1 to n do

    write (mas[i],' '); / /выводим числа из массива на экран

    writeln; / /переходим на новую строку для вывода

    min:=1000000; / /задаем начальное значение минимального числа (максимально возможное)

    for i:=1 to n do

    if mas[i]
    write (' минимальный элемент массива - ', min); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из n элементов. Найти наименьший элемент массива. Написать в паскале абс ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
Дан массив из 10 элементов заполнить с клавиатуры: 1) вывести массив 2) вывести массив на экран 3) поменять местами 6 и 9 элемент массива 4) найти max элементов массива
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)