Задать вопрос
22 января, 15:09

Найти сумму всех трёхзначных чисел, кратных 77. Паскаль. (использовать цикл while)

+2
Ответы (1)
  1. 22 января, 18:54
    0
    program zz1;

    var i, s:integer; / / задаем переменные целого типа

    begin

    i: = 100; / / задаем начальное значение для параметра цикла

    while i < = 999 do / / организуем цикл, пока параметр цикла не достигнет последнего трехзначного числа

    begin

    if i mod 77 = 0 then s: = s + i; / / проверяем, если трехзначное число делится на семьдесят семь без остатка, то добавляем его в сумму

    i: = i + 1; / / увеличиваем параметр цикла на единицу

    end;

    writeln (' сумму всех трехзначных чисел, кратных 77 = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму всех трёхзначных чисел, кратных 77. Паскаль. (использовать цикл while) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Вычислить значение переменной Y при заданном значении N: Y=1/1+1/2+1/3 + ... + 1/N. использовать цикл типа ДО. (Паскаль) 2. Найти все целые двузначные числа, удовлетворящие условию: остаток от деления на 3 равен 2. (Паскаль)
Ответы (1)
Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n - вводится с клавиатуры) если n-четное, и сумму кубов чисел от 1 до n, если n-нечетное. Использовать цикл WHILE
Ответы (1)
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4.
Ответы (1)