Задать вопрос
26 февраля, 19:25

У бабушки есть куры и утки. Их всего 20 штук. Одна курица весит 3 кг, одна утка 10 кг? Составить программу, которая позволяет, ввести количество кур, и на ходить общий вес птиц?

+3
Ответы (1)
  1. 26 февраля, 23:23
    0
    program massa;

    var m: real; / /m - масса птиц

    k: integer; / /k - количество кур

    begin

    writeln ('Введите количество кур');

    readln (k); /

    m : = k * 3 + (20 - k) * 10; / /формула для расчета массы:

    //количество кур умножаем на 3 кг, количество уток - на 10 кг.

    //Находим сумму масс.

    write ('Масса всех птиц: ', m : 3 : 1, ' кг')

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «У бабушки есть куры и утки. Их всего 20 штук. Одна курица весит 3 кг, одна утка 10 кг? Составить программу, которая позволяет, ввести ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу, которая позволяет ввести элементы массива a[1 ... 10] с клавиатуры и выводит на экран количество отрицательных элементов и их индексы.
Ответы (1)
Составить программу, которая позволяет ввести две строки одинаковой длины и определяет, сколько раз у них совпадают символы, стоящие в одной и той же позиции.
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
Напишите программу, которая позволяет ввести три вещественных числа и выводит на экран: разность целых частей первого и второго чисел; косинус удвоенного произведения первого на третье; сумму квадратов синуса второго числа и косинуса третьего.
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)