Задать вопрос
26 февраля, 11:37

Написать программу в Pascal ABC. Последовательность чисел заканчивающихся на 0 (ноль). Необходимо найти количество чисел у которых количество десятков "4" или "6".

+5
Ответы (1)
  1. 26 февраля, 12:39
    0
    Var i, j, sum: integer;

    a: array [1 ... 10000] of integer;

    begin

    //ввод необходимых характеристик

    Writeln ('Введите числа (0 - признак окончания ввода) ');

    a[1]:=1;

    i:=1;

    while (a[i]0) do

    begin

    i:=i+1;

    readln (a[i]);

    while (a[i] mod 10 0) do

    begin

    Write ('Введите числo кратное 10. '); readln (a[i]);

    end;

    end;

    i:=i-1;

    //нахождение количества чисел, подходящих условию

    sum:=0;

    for j:=2 to i do

    if (a[j] mod 100 = 40) or (a[j] mod 100 = 60) then sum:=sum+1;

    Writeln (sum);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в Pascal ABC. Последовательность чисел заканчивающихся на 0 (ноль). Необходимо найти количество чисел у которых ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу которая вводит последовательность целых чисел заканчивающихся нулём и определяет сколько из этих чисел удовлетворяет условию: сумма значений цифр десятичной записи числа равно 10
Ответы (1)
С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1) Количество четных чисел. 2) Сумму чисел, заканчивающихся на 5 и положительных Найти сумму чисел: 5+10+15+20+ ...+n
Ответы (1)
Дано целое неотрицательное число N, определите число десятков в нем (предпоследнюю цифру числа). Если предпосленей цифры нет, то можно считать, что число десятков равно нулю. (Напишите программу для решения в Pascal. ABC)
Ответы (1)
1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. Программа получает на вход количество чисел в последовательности и сами числа 2. Измените программу так, чтобы определялось произведение чисел. 3.
Ответы (1)
Как написать в pascal abc программу которая Определяет является ли последовательность арифметической прогрессией
Ответы (1)