Задать вопрос

Составить алгоритм и программу вычисления функции f (x) при произвольном x:f (x) = { (2x+4, если-2≤x≤-1; 2x^2, если-12 функция f (x) не определена.

+2
Ответы (1)
  1. 3 августа, 05:36
    0
    program zz1;

    var x:real; / / задаем переменную не целого типа

    begin

    write ('введите исходное значение х '); / / вводим с клавиатуры исходное значение х

    read (x);

    if x < - 2 then write (' функция не определена '); / / в зависимости от введенного числа х и заданного диапазона выводим один из пяти ответов

    if x > 2 then write (' функция не определена ');

    if (x > = - 2) and (x < = - 1) then write (2 * x + 4);

    if (x > - 1) and (x < = 1) then write (2 * x * x);

    if (x > 1) and (x < = 2) then write (-2 * x + 2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить алгоритм и программу вычисления функции f (x) при произвольном x:f (x) = { (2x+4, если-2≤x≤-1; 2x^2, если-12 функция f (x) не ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1) Алгоритм вычисления значения функции F (n), где n - натуральное число, задан следующими соотношениями:F (1) = 1, F (2) = 1F (n) = F (n-2) * (n-1) + 2, при n > 2 Чему равно значение функции F (8) ? В ответе запишите только натуральное число.
Ответы (1)
Запишите алгоритм вычисления для заданного количества суток (tfh) количества часов (Л), минут (т) и секунд (с). Выполните вычисления для заданных значений переменной tfh. Алгоритм: tfh 1 2 1/2 h т с
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N. Проверьте алгоритм трассировкой. Напишите программу в Паскале.
Ответы (1)
Дана цепочка символов СТОП. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм) ?
Ответы (1)