Задать вопрос

1. Определить самого высокого ученика класса (в классе 27 учеников). 2. Было куплено 10 арбузов различного веса. Определить вес всей покупки. Решить в Паскале

+5
Ответы (1)
  1. 9 октября, 07:07
    0
    1. program zz1;

    const n = 27; / /задаем количество элементов в массиве

    var i, max1, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (51) + 150;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    max1:=0;

    for i:=1 to n do / / находим максимальный элемент и его номер

    if m[i]>max1 then max1:=m[i];

    writeln (' самый высокий ученик в классе с ростом = ', max1,' см'); / / выводим ответ

    end.

    2. program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (1501);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    s:=s + m[i]; / / получаем сумму

    writeln (' вся покупка весит = ', s,' грамм'); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Определить самого высокого ученика класса (в классе 27 учеников). 2. Было куплено 10 арбузов различного веса. Определить вес всей ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)
Составить программу которая выводит на экран самого высокого ученика в классе.
Ответы (1)
1. Напишите программу вычисления веса идеального мужчины по формуле: Ид. Вес-Рост в см - 100 Значение роста вводится с клавиатуры. Результат вывести в следующем виде: Для мужчины ростом 165 см идеальный вес равен 65 кг. 2.
Ответы (1)
Задача в Паскале. с помощью оператора while напишите программу определения идеального веса для взрослых по формуле: ид. вес=рост-100. выход из цикла: значение роста=250
Ответы (1)
Вы приобрели котенка. Каждый вечер вы определяете его вес с помощью весов. Как можно описать на Паскале массив, в котором будут храниться значения веса котенка в течение месяца (например, мая) ?
Ответы (1)