Задать вопрос

Составить программу которая выводит на экран самого высокого ученика в классе.

+3
Ответы (1)
  1. 21 ноября, 16:49
    0
    Программа на c++:

    #include

    #include

    using namespace std;

    int main () {

    setlocale (LC_ALL, "Russian"); / /Функция подключает русский язык на консоли.

    int n; / / Число учеников в классе.

    int student; / /В эту переменную поочередно будем задавать рост каждого ученик.

    int max_student = 0; / / В этой переменной храним текущий максимальный рост.

    int n_max_student = 0; / / Номер ученика с максимальным текущим ростом.

    cin >> n; / / Число учеников вводится с клавиатуры.

    for (int i = 0; i < n; i++) {

    cin >> student; / / Поочередно перебираем рост всех учеников.

    if (student > max_student) {

    max_student = student; / / Если рост ученика больше предыдущего запоминаем его как текущий максимальный.

    n_max_student = i + 1; / / Так же запоминаем номер этого ученика.

    }

    }

    cout << "Самый высокий ученик номер: " << n_max_student << ". Его рост: " << max_student << ".";

    return 0;

    }
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу которая выводит на экран самого высокого ученика в классе. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.2) Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.
Ответы (1)
Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив, в котором заменены на противоположные знаки элементов исходного массива.
Ответы (1)
Составьте программу которая выводит на экран пример на умножение двух однозначных чисел, запрашивает ответ пользователя. проверяет его и выводит соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись". а также правильный результат.
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)